Search found 10 matches

by DCMotoring
Tue Oct 22, 2019 1:22 pm
Forum: Tech Forum
Topic: Oil Pressure Light Always On
Replies: 3
Views: 204

Re: Oil Pressure Light Always On

I do have the oxygen sensor light, but the emissions equipment was removed when I purchased the car. I'll have to dig around to see if there is a wire down there but I did unplug the engine connector and the light was still on so next step might be to remove the instrument panel and follow the wire ...
by DCMotoring
Thu Oct 17, 2019 5:10 pm
Forum: Tech Forum
Topic: Oil Pressure Light Always On
Replies: 3
Views: 204

Oil Pressure Light Always On

Tested switch and replaced just in case. The oil pressure light is on regardless of whether it is connected to the switch. Solid light, does not flicker or respond to any changes in oil pressure/RPM. Tracing the wire from the switch, it goes into the engine harness and into the fuse box and from the...
by DCMotoring
Thu Jul 25, 2019 12:41 pm
Forum: Tech Forum
Topic: No Crank, No Start
Replies: 1
Views: 202

No Crank, No Start

My '78 530i gets full power (lights, interior accessories) when key is in ON position but absolutely nothing happens with starter when I attempt to start it. Battery voltage at starter is about 12.5v and there is about 7.5v coming from the ignition switch when in the ON position. I connected a jumpe...
by DCMotoring
Wed Feb 20, 2019 1:27 pm
Forum: Tech Forum
Topic: Suspension Trouble Shooting
Replies: 9
Views: 553

Re: Suspension Trouble Shooting

Strangely the back seems fine and the rear fenders are pretty clear of the tires. But the front fenders do rub the tires. I've had the car for almost 10 years and I didn't have any issues with the large tires (yes, I've got 235/45-17s) until about 5 years ago when the wheels started rubbing on the f...
by DCMotoring
Wed Feb 20, 2019 11:32 am
Forum: Tech Forum
Topic: Suspension Trouble Shooting
Replies: 9
Views: 553

Re: Suspension Trouble Shooting

Tires on the fender wells. It also doesn't help that there wasn't much clearance to begin with! That's a good idea to check the ride height. I did notice one side might be slightly lower than the other so might be time for new strut inserts and springs. What kind of springs did you use? And I'm assu...
by DCMotoring
Tue Feb 19, 2019 4:06 pm
Forum: Tech Forum
Topic: Suspension Trouble Shooting
Replies: 9
Views: 553

Suspension Trouble Shooting

Last summer my e12 started bottoming out while going over bumps and dips at moderate speeds. I replaced the front axle support bushings several years ago but did not get to the control arm bushings. Strut mounts aren't creaking and the car isn't bouncing. But the only thing I can think of is either ...
by DCMotoring
Wed Sep 23, 2015 7:10 pm
Forum: Tech Forum
Topic: Intermittent shut off, white smoke under steering column
Replies: 0
Views: 1572

Intermittent shut off, white smoke under steering column

A few weeks ago, my 530i started to shut off after running for a few minutes. After shutting off, the combo relay clicks and the ignition buzzer goes on and off. Thinking it was the combo relay, I soldered some of the connections but it didn't fix the issue. Then when I was sitting in the driver sea...
by DCMotoring
Wed May 23, 2012 1:41 pm
Forum: Tech Forum
Topic: Start Then Stutter at Open Throttle
Replies: 14
Views: 2600

Start Then Stutter at Open Throttle

I have done a bit of searching but haven't found any answers directly related to my problem. The engine starts and idles fine but when I open the throttle the engine stutters and nearly stalls. Once it warms up, it operates as normal. I recently replaced the fuel pump and all the fuel lines. I was h...
by DCMotoring
Mon Apr 23, 2012 11:54 am
Forum: Tech Forum
Topic: Temp Gauge - Max
Replies: 2
Views: 844

Thanks for the response Mike! I'll focus on seeing whether it is a grounding issue first, as it is the most simple solution. To be clear though, it was erratic when it first started but now simply moves up steadily to max reading within a few minutes after I start the car and stays there. There is n...
by DCMotoring
Fri Apr 20, 2012 3:24 pm
Forum: Tech Forum
Topic: Temp Gauge - Max
Replies: 2
Views: 844

Temp Gauge - Max

I've owned my e12 ('78 530i) for a couple years but I'm a novice when it comes to my mechanical knowledge. Last winter, the car was having an issue starting. The ignition warning buzzer wouldn't go on when I turned the ignitition to the On position. However, it would start after spraying some gum cu...