Search found 17 matches

by Dale
Thu Jun 11, 2020 8:04 pm
Forum: Tech Forum
Topic: Radiator Specs
Replies: 1
Views: 117

Radiator Specs

I was wondering if someone had the measurements for a e12 radiator. I am trying to work with Wizard Cooling to get a radiator for my car. The one they list on the website for my e12 based 1980 633csi looks to be the same as the e28 one. I am hoping I can get the correct specs, have them build me one...
by Dale
Mon Feb 03, 2020 3:38 pm
Forum: Tech Forum
Topic: Red Line in gearbox and differential?
Replies: 5
Views: 844

Re: Red Line in gearbox and differential?

Been using in mine with no issues.

Dale
by Dale
Tue Feb 26, 2019 8:17 pm
Forum: Tech Forum
Topic: Electrical Problem
Replies: 7
Views: 1008

Re: Electrical Problem

Should be mounted to one of the fenders - believe it is the battery side. Looks like two white sausages with wires coming out.

Dale
Buffalo, NY
by Dale
Sun Aug 26, 2018 8:49 pm
Forum: Tech Forum
Topic: HELP with Blower Fan Dial
Replies: 6
Views: 906

Re: HELP with Blower Fan Dial

A complete PITA. You will have springs and ball bearings all over the place.
by Dale
Sun Sep 24, 2017 10:03 am
Forum: Tech Forum
Topic: No power at WOT
Replies: 9
Views: 1167

Ron wins the chicken dinner. I went back into car - harness was caught up and the leads to the TPS were caught up. Once I got them loose, I switched them. Appears to be working.

Cheers
Dale
by Dale
Wed Sep 20, 2017 7:33 pm
Forum: Tech Forum
Topic: No power at WOT
Replies: 9
Views: 1167

I have put about 100 miles on the car since disconnecting the TPS. Acceleration at the top end isn't crazy like I remember, but there is power. Interesting thing is my gas mileage is about 50% better, which leadss me to believe that somehow the ECU was telling the car to run very rich. Not sure if t...
by Dale
Sun Sep 17, 2017 5:37 am
Forum: Tech Forum
Topic: No power at WOT
Replies: 9
Views: 1167

Update

I spent some time on the phone with Ron last week, and finally got back under the hood. Besides the WOT issue, car was beginning to stall out intermittently while searching for idle. I unplugged both throttle switches, and I have power at WOT and the idle improved. I am going to check again to make ...
by Dale
Sat Jul 15, 2017 8:13 am
Forum: Tech Forum
Topic: No power at WOT
Replies: 9
Views: 1167

Thanks for the feedback - still chasing this down, so this is helpful.

Dale
by Dale
Wed May 24, 2017 5:08 am
Forum: Tech Forum
Topic: No power at WOT
Replies: 9
Views: 1167

No power at WOT

1980 633csi with L-Jet system. Motor rebuilt about 5K ago. Ever since I got it back, the car will lose all power when at wide open throttle. It doesn't matter what gear I am in. Once I back off the throttle, normal operations continue. I cannot replicate this parked in the garage manually operating ...
by Dale
Sat Jan 30, 2016 3:40 pm
Forum: Tech Forum
Topic: Sealant for windshield washer bottle hoses connections?
Replies: 6
Views: 1185

I went through this recently on my car. I couldn't get them to seal without the Oetiker (sp) clamps. I was able to buy them on Amazon. I believe I bought the new braided hose from BavAuto in bulk and cut to fit.

Dale
by Dale
Sun Oct 18, 2015 6:28 am
Forum: Tech Forum
Topic: Electrical grmilin - Turn signal and radio dead
Replies: 2
Views: 976

IIRC, these are all on the same circuit. Are you running an aftermarket stereo? That could be causing a drain on the circuit. I replaces the brake lights with LED bulbs to cut down on the drain in the circuit to stop similar symptoms.
by Dale
Sat Sep 12, 2015 2:57 pm
Forum: Tech Forum
Topic: Heater Blower Issues
Replies: 1
Views: 648

Heater Blower Issues

1980 633csi. E12 based car. Last summer, I totally rehabbed the climate control panel because the resistor inside the panel that controls the fan speed burnt out. I used Peter's great write-up. The AC now blows with variable fan speeds. I noticed when trying to use the front defogger that there was ...
by Dale
Tue Aug 18, 2015 6:28 pm
Forum: Tech Forum
Topic: Heater, A/C blower ring inoperative
Replies: 5
Views: 1356

I undertook this project last year. The resistor plate behind the dial finally fried. I had all fan speeds, only high, then none. Job is a complete PITA. It took me 2 years to get up the courage to do it. Take your time, and use the FAQ; it is invaluable. If you have a spare to look at while you dis...
by Dale
Tue Aug 26, 2014 7:23 am
Forum: Tech Forum
Topic: Heater Fan Control Repair
Replies: 2
Views: 847

Thanks Mike. I have a can of that in the garage. I will start there.
by Dale
Mon Aug 25, 2014 2:27 pm
Forum: Tech Forum
Topic: Heater Fan Control Repair
Replies: 2
Views: 847

Heater Fan Control Repair

I am about to tackle is messy job after reading Peters FAQ article on and off for the past 10 years. I have no fan control over either heater or AC, so it must be the resistor. I have taken apart the heater control from the donor car. Any suggestoions what to lube the contacts with when I re-assembl...