No click or fuel pump hum when AFM flap is opened?

Post your E12 technical questions and comments here. Please, no off-topic posts.

Moderators: Mike W., Pierre

Post Reply
canada karl
Posts: 633
Joined: Tue Jan 06, 2009 3:50 pm

No click or fuel pump hum when AFM flap is opened?

Post by canada karl » Sun Jul 07, 2019 10:19 am

So not getting fuel. Checked the pump as per the manual. Turns out the problem is somewhere else. I'm assuming a broken connection or relay? Where's the best place to start looking? Where is the pump relay located? What other common causes in the electrical?
1976 530i. BMW 59 Triumph TR3A(rolling resto). 67 Triumph TR4A(salvageable). 86 900S Winter car

waltb
Posts: 27
Joined: Tue Jan 13, 2009 9:20 pm
Location: South Western, PA

Re: No click or fuel pump hum when AFM flap is opened?

Post by waltb » Sun Jul 07, 2019 11:17 am

I have had various fuel pump problems over the years with my 528i. None were ever the fuel pumps.

First check using a multimeter if the AFM contacts are closing. I have had those contacts inside go bad. You can pop off the plastic cover, in addition to the AFM resistor pc board you will see two brass contacts. You can spray them with contact cleaners or something like De-Oxit. Maybe run a piece of paper through them. Do not file them, that will ruin them. You can rtv the AFM plastic cover back on. You can also jump the terminals before you open anything at the AFM connector to see if that turns on the combo relay and the fuel pumps

Second is the combo relay. It is the dual relay usually above the brake booster. One relay controls power to the L-jet injection and the other side to the fuel pump. In side, the relays are mounted on a pc board. I have seen the solder joints go bad. It was one of the most difficult intermittant failure that I have ever debugged. I could drive my car weeks and then it would go bonkers stalling. I have carefully removed the cover of the relays and reflowed the solder joints with a soldering iron and the relay worked fine for many years. You can jump at the combo relay connector to see if the fuel pumps turn on. Also look at all the crimp terminals in the relay connector. Make sure none look super corroded or pushed down and out of the connector.

I believe the schematics of the combo relay circuit etc are available somewhere on this site.

If you search in the archives there has been much discussion in the distant past about this issue.

Good luck,

waltb

canada karl
Posts: 633
Joined: Tue Jan 06, 2009 3:50 pm

Re: No click or fuel pump hum when AFM flap is opened?

Post by canada karl » Sun Jul 07, 2019 2:07 pm

Where are the terminals you say i can jump to see if the combo relay & pump will turn on before I take the cover off the the AFM? Does the AFM cover just pry off? This is the first time I've had to tackle this problem and I've had the car for 20 years!
1976 530i. BMW 59 Triumph TR3A(rolling resto). 67 Triumph TR4A(salvageable). 86 900S Winter car

User avatar
Robert Bondi
Posts: 261
Joined: Sun Jan 11, 2009 12:33 am
Location: Austin, TX

Re: No click or fuel pump hum when AFM flap is opened?

Post by Robert Bondi » Sun Jul 07, 2019 6:46 pm

I also like to jump pins 36 and 39 on the AFM. That bypasses the AFM flap fuel cutoff and you can
test fuel pump operation without starting car. Pump will run with ignition in "ON" position before cranking. Combo relay is certainly a common culprit for your problem, as discussed.
Robert
77 530i
77 Euro 528

User avatar
Mike W.
Posts: 2430
Joined: Wed Aug 30, 2006 12:12 am
Location: Sonoma County

Re: No click or fuel pump hum when AFM flap is opened?

Post by Mike W. » Mon Jul 08, 2019 12:02 am

Robert Bondi wrote:
Sun Jul 07, 2019 6:46 pm
I also like to jump pins 36 and 39 on the AFM. That bypasses the AFM flap fuel cutoff and you can
test fuel pump operation without starting car. Pump will run with ignition in "ON" position before cranking. Combo relay is certainly a common culprit for your problem, as discussed.
No, there is no prime function on any US spec E12, 23, 24 or 28. Fuel pump does not run until cranking or AFM flap movement. E21 K jet cars did have a prime function where the pump would run for 3 or 5 seconds or the like. But not L jet cars.

I don't recall the pin numbers, but jumping the FP contacts by the AFM is of value. One time I was having bizarre problems with fuel on vacation. I jumped the AFM contacts with a sewing pin just stuck thru the insulation, and continued on with out issue.
Mike W.



1980 528i, 3.5 euro, 5 speed conversion
1981 528i, 3.6, Recaros and more. Project
1998 328is, quick and efficient, but not satisfying
2000 528iit, Vacation mobile/wife's grocery getter

waltb
Posts: 27
Joined: Tue Jan 13, 2009 9:20 pm
Location: South Western, PA

Re: No click or fuel pump hum when AFM flap is opened?

Post by waltb » Mon Jul 08, 2019 5:45 pm

And the link from the FAQ for a wiring diagram of the L-Jet fuel injections system which includes the fuel pump schematics is:

http://www.firstfives.org/faq/ljet/528i ... ematic.PDF

There are also some other info in our FAQ to guide you to the right pins to short to see if the pumps run.

waltb

canada karl
Posts: 633
Joined: Tue Jan 06, 2009 3:50 pm

Re: No click or fuel pump hum when AFM flap is opened?

Post by canada karl » Tue Jul 09, 2019 3:14 pm

Thanks for the info. Going to check the AFM today.
1976 530i. BMW 59 Triumph TR3A(rolling resto). 67 Triumph TR4A(salvageable). 86 900S Winter car

Post Reply