RHD - accelerator system not returning

Post your E12 technical questions and comments here. Please, no off-topic posts.

Moderators: Mike W., Pierre

Post Reply
garyinwestoz
Posts: 327
Joined: Thu Jan 29, 2009 9:05 pm
Location: perth, australia
Contact:

RHD - accelerator system not returning

Post by garyinwestoz »

I wonder if anyone with a RHD car can test a part for me - on the accelerator linkage system.

test the pedal return by disconnecting the short rod from the pedal assembly thats just below the brake master cylinder in the engine bay. No 11 on drawing 4785

now , is the pedal stiff or light?


If I may
the accelerator system on RHD cars has a series of bars and linkages to connect the pedal to the Throttle assembly.

Image

Image
(dwg 04790 seems to show 2 different linkage systems - bracket No 4 is what I have)

Image

there are
three return springs - one at pedal, one at rotating bracket on left side of block and one at throttle body
and 3 push pull bars
1 x rotating bracket ( left side of block)
2 x rotating levers ( below brake master cylinder) and ) one at left hand end of rotating torsion bar)
1 x rotating torsion bar. (runs along firewall)

There is a (torsion) bar that runs along the fire wall connecting the pedal( RHD) to the left side of the block - this bar rubs again my firewall insulation blanket.

After disconnecting all the parts and reconnecting - I reckon the bar at the pedal assembly is sorta stuck

any thoughts on how to unstick this bar?

here is a photo of a spare pedal assembly showing this bar - this one is kinda stiff too!

No 2- 10 on dwg 0004785

Image
77 528i -4 speed manual getting rusty
76 525 - 4 speed, LPG and holley carb- restoring
81 528i - auto - to be relicensed with a 3.5 (83 735i)
80 528i auto - ready to relicense
79 SA ? 528i auto
79 528i auto parts car
86 525e 5 speed manual- dd
Post Reply